summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
index 8bb8f6408..c858d5b4b 100644
--- a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
@@ -6,13 +6,13 @@ PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit autotools pkgconfig
+inherit meson
+inherit pkgconfig
inherit systemd
PACKAGECONFIG ?= ""
-PACKAGECONFIG[7seg] = "--enable-7seg,--disable-7seg,,udev"
+PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
-DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-dbus-interfaces"
@@ -20,7 +20,7 @@ DEPENDS += "systemd"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-host-postd"
-SRCREV = "66efa632e25854ed5fba0166fe5c3bdd6761f20b"
+SRCREV = "bf002b46d5fb2f176fb22e48c6f1172bc970e17d"
SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
POST_CODE_BYTES ?= "1"
@@ -29,11 +29,9 @@ SERVICE_FILE = "lpcsnoop.service"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
-EXTRA_OECONF = " \
- SNOOP_DEVICE="${SNOOP_DEVICE}" \
- POST_CODE_BYTES="${POST_CODE_BYTES}" \
- SYSTEMD_TARGET="multi-user.target" \
-"
+EXTRA_OEMESON += "-Dsnoop-device=${SNOOP_DEVICE}"
+EXTRA_OEMESON += "-Dpost-code-bytes=${POST_CODE_BYTES}"
+EXTRA_OEMESON += "-Dsystemd-target=multi-user.target"
POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
SERVICE_FILE_7SEG = " \