summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 3db77d998..f7d2413ef 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -4,8 +4,8 @@ inherit useradd
USERADD_PACKAGES = "${PN}"
# add a user called httpd for the server to assume
-USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb"
-GROUPADD_PARAM_${PN} = "web; redfish"
+USERADD_PARAM:${PN} = "-r -s /usr/sbin/nologin bmcweb"
+GROUPADD_PARAM:${PN} = "web; redfish"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
@@ -13,7 +13,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
SRC_URI = "git://github.com/openbmc/bmcweb.git"
PV = "1.0+git${SRCPV}"
-SRCREV = "ff3f835ad47f7a4f61d5fe9345dccdd3e496c47c"
+SRCREV = "7bb985eeb0930905c2f4d551e895dd5293094931"
S = "${WORKDIR}/git"
@@ -37,7 +37,7 @@ DEPENDS = " \
${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
jsnbd \
phosphor-mapper \
"
@@ -47,7 +47,7 @@ do_install_ptest() {
cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
}
-FILES_${PN} += "${datadir}/** "
+FILES:${PN} += "${datadir}/** "
EXTRA_OEMESON = " \
@@ -56,6 +56,6 @@ EXTRA_OEMESON = " \
-Dyocto-deps=enabled \
"
-SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket"
+SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
FULL_OPTIMIZATION = "-Os "