summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb18
1 files changed, 13 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 4dfbbcf27..6012ffe1f 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -13,20 +13,28 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
SRC_URI = "git://github.com/openbmc/bmcweb.git"
PV = "1.0+git${SRCPV}"
-SRCREV = "1bf712bcd6b8d06a5d412cdf03cdc05cb6d25901"
+SRCREV = "929d4b57f10bc4200e16b71fbcf32521d8cc23c1"
S = "${WORKDIR}/git"
-DEPENDS = "openssl zlib boost libpam sdbusplus gtest nlohmann-json libtinyxml2 "
+DEPENDS = "openssl \
+ zlib \
+ boost \
+ boost-url \
+ libpam \
+ sdbusplus \
+ gtest \
+ nlohmann-json \
+ libtinyxml2 "
RDEPENDS_${PN} += "jsnbd"
FILES_${PN} += "${datadir}/** "
-inherit cmake
+inherit meson
-EXTRA_OECMAKE = "-DBMCWEB_BUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON"
+EXTRA_OEMESON = "--buildtype=minsize -Dtests=disabled -Dyocto-deps=enabled"
SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket"
-FULL_OPTIMIZATION = "-Os -pipe "
+FULL_OPTIMIZATION = "-Os "