summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory/obmc-inventory_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory/obmc-inventory_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/obmc-inventory_git.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/obmc-inventory_git.bb b/meta-phosphor/recipes-phosphor/inventory/obmc-inventory_git.bb
deleted file mode 100644
index 56286123e..000000000
--- a/meta-phosphor/recipes-phosphor/inventory/obmc-inventory_git.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "Phosphor Inventory Generation"
-DESCRIPTION = "Generates inventory data from the machine readable workbook"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit mrw-xml
-
-S = "${WORKDIR}/git"
-
-PROVIDES += "virtual/obmc-inventory-data"
-RPROVIDES_${PN} += "virtual-obmc-inventory-data"
-
-inherit allarch
-inherit mrw-rev
-
-DEPENDS += "mrw-native mrw-api-native"
-
-SRC_URI += "${MRW_TOOLS_SRC_URI}"
-SRCREV = "${MRW_TOOLS_SRCREV}"
-
-FILES_${PN} += "${datadir}/inventory"
-
-do_compile() {
- ${STAGING_BINDIR_NATIVE}/perl-native/perl ${S}/inventory.pl \
- -x ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} -o inventory.json
-}
-
-do_install() {
- install -d ${D}${datadir}/inventory
- install -m 0644 inventory.json ${D}${datadir}/inventory/inventory.json
-}