summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb
new file mode 100644
index 000000000..fe9e6ed05
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Recipe to create AssetTag property in inventory manager"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-inventory-manager
+
+PROVIDES += "virtual/phosphor-inventory-manager-assettag"
+
+SRC_URI += "file://assettag.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # This recipe would provide the yaml for inventory manager to
+ # create AssetTag property at startup
+
+ install -d ${D}${base_datadir}/events.d/
+ install assettag.yaml ${D}${base_datadir}/events.d/assettag.yaml
+}