summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
new file mode 100644
index 000000000..2dd6e281c
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Recipe to create AssetTag property in inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+PROVIDES += "virtual/phosphor-inventory-manager-assettag"
+S = "${WORKDIR}"
+
+SRC_URI = "file://assettag.yaml"
+
+do_install() {
+ install -D assettag.yaml ${D}${base_datadir}/events.d/assettag.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/assettag.yaml"