summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index d52f33038..8f390f554 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -3,13 +3,29 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEPENDS += "systemd"
SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https"
-SRCREV = "d818c2ff85c011be29c8d3047e516a5e032a1923"
+SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
-# this patch has been submitted to ipmitool upstream and is in review
+# TODO: when a new company joins the OpenBMC project by signing
+# a CLA, if they have an enterprise number on file with the
+# IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
+# needs to be updated to add their entry. The canonical
+# version of the file is locatede here:
+# https://www.iana.org/assignments/enterprise-numbers
+#
+# This file is manually downloaded so it can be versioned
+# instead of having the makefile download it during do_compile
SRC_URI += " \
- file://0001-create_pen_list-only-print-if-values-are-set.patch \
+ file://enterprise-numbers \
"
+# make sure that the enterprise-numbers file gets installed in the root FS
+FILES_${PN} += "/usr/share/misc/enterprise-numbers"
+do_compile_prepend() {
+ # copy the SRC_URI version of enterprise-numbers
+ # to the build dir to prevent a fetch
+ cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
+}
+
S = "${WORKDIR}/git"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"