summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb18
1 files changed, 14 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
index d79078a1b..4ee1e16a3 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
@@ -7,17 +7,17 @@ inherit autotools pkgconfig
inherit obmc-phosphor-systemd
inherit obmc-phosphor-ipmiprovider-symlink
inherit phosphor-ipmi-fru
-inherit pythonnative
+inherit python3native
-require ${PN}.inc
+require ${BPN}.inc
DEPENDS += " \
virtual/phosphor-ipmi-fru-inventory \
virtual/phosphor-ipmi-fru-properties \
systemd \
sdbusplus \
- python-mako-native \
- python-pyyaml-native \
+ ${PYTHON_PN}-mako-native \
+ ${PYTHON_PN}-pyyaml-native \
phosphor-ipmi-host \
phosphor-mapper \
autoconf-archive-native \
@@ -25,12 +25,17 @@ DEPENDS += " \
cli11 \
"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI += "file://of-name-to-eeprom.sh"
+
SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
S = "${WORKDIR}/git"
HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
+FILES_${PN} += "${bindir}/of-name-to-eeprom.sh"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
@@ -39,3 +44,8 @@ EXTRA_OECONF = " \
YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
"
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
+}