summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb39
1 files changed, 28 insertions, 11 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
index a084387f2..370e585ea 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
@@ -7,27 +7,44 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig
-inherit obmc-phosphor-systemd
+inherit systemd
DEPENDS += "autoconf-archive-native"
+DEPENDS += "cli11"
DEPENDS += "phosphor-mapper"
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
-RDEPENDS_${PN} += "iptables"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
-SRC_URI += "file://ipmi-net-firewall.sh"
-SRCREV = "8af90ebcc552e243ae85aa9e9da1a00fbecab56c"
+SRCREV = "052b7cf37411a1bb69af1e6ce541a16021fffa9f"
S = "${WORKDIR}/git"
-do_install_append() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/ipmi-net-firewall.sh \
- ${D}${bindir}/ipmi-net-firewall.sh
-}
+FILES_${PN} += " \
+ ${systemd_system_unitdir}/${PN}@.service \
+ ${systemd_system_unitdir}/${PN}@.socket \
+ "
+
+# If RMCPP_IFACE is not set by bbappend, set it to default
+DEFAULT_RMCPP_IFACE = "eth0"
+RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
+# install parameterized service and socket files
SYSTEMD_SERVICE_${PN} = " \
- ${PN}.service \
- ${PN}.socket \
+ ${PN}@${RMCPP_IFACE}.service \
+ ${PN}@${RMCPP_IFACE}.socket \
"
+
+# To add another RMCPP interface, add similar lines to the
+# following lines in a bbappend:
+#
+# ALT_RMCPP_IFACE = "eth1"
+# SYSTEMD_SERVICE_${PN} += " \
+# ${PN}@${ALT_RMCPP_IFACE}.service \
+# ${PN}@${ALT_RMCPP_IFACE}.socket \
+# "
+
+# Also, be sure to enable a corresponding entry in the channel
+# config file with the same 'name' as the interfaces above
+# Override the default phosphor-ipmi-config.bb with a bbappend
+