summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb15
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb26
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb3
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory-native.bb22
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory/channel.yaml6
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb3
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb1
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb2
9 files changed, 47 insertions, 33 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb b/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
new file mode 100644
index 000000000..aba85bc71
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "http://github.com/openbmc/ipmi-blob-tool"
+SUMMARY = "Library and Host-side tool for talking to OpenBMC IPMI BLOB handlers."
+DESCRIPTION = "This package provides a library for the BMC and host for core blob mechanics and host-side binaries for talking to OpenBMC IPMI BLOB handlers."
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+
+DEPENDS += "autoconf-archive-native"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/ipmi-blob-tool"
+SRCREV = "a8356420078bb7e7580fe6c42818e20203c7cbfc"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb
new file mode 100644
index 000000000..8d45667cd
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb
@@ -0,0 +1,26 @@
+HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
+SUMMARY = "BMC Generic Binary Blob Store via OEM IPMI Blob Transport"
+DESCRIPTION = "This package provides a read/write/serialize abstraction for storing binary data through IPMI blobs"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-ipmi-blobs"
+DEPENDS += "phosphor-logging"
+DEPENDS += "protobuf-native"
+DEPENDS += "protobuf"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
+SRCREV = "8ca234e6986763ffaddcf56b49fecdfe96a60182"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+BLOBIPMI_PROVIDER_LIBRARY += "libbinarystore.so"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
index 939c9432d..a82e9f611 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
@@ -12,10 +12,11 @@ inherit obmc-phosphor-ipmiprovider-symlink
DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "phosphor-logging"
+DEPENDS += "ipmi-blob-tool"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
-SRCREV = "97898c9056e48d2aa0ec1ec8251377c587b7caee"
+SRCREV = "de8a16e2e85f49e142461b7e6fe901d3f8740fdf"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory-native.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory-native.bb
deleted file mode 100644
index 043200a71..000000000
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory-native.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Sample channel configuration for phosphor-host-ipmid"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-ipmi-host
-
-PROVIDES += "virtual/phosphor-ipmi-channel-config"
-
-SRC_URI += "file://channel.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- # This recipe is supposed to create an output yaml file with
- # a sample output file.
-
- DEST=${D}${sensor_datadir}
- install -d ${DEST}
- install channel.yaml ${DEST}/channel.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory/channel.yaml b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory/channel.yaml
deleted file mode 100644
index 819f25198..000000000
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-channel-inventory/channel.yaml
+++ /dev/null
@@ -1,6 +0,0 @@
-# Channel Number (must be unique) is the key
-1:
- # ifName the ethernet device name (used in the dbus path)
- ifName: eth0
-2:
- ifName: eth1
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb
index ac19cf2e8..7157c7e12 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ethstats_git.bb
@@ -14,7 +14,7 @@ DEPENDS += "phosphor-ipmi-host"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats"
-SRCREV = "539f03f54621cad9edc7dee5a9b570c96f486dfe"
+SRCREV = "d087d81ae3cad0df1d641c87144909e46fcb20fb"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 8484ddf5d..7dd4cfcf2 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -13,10 +13,11 @@ DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-ipmi-blobs"
DEPENDS += "phosphor-logging"
DEPENDS += "sdbusplus"
+DEPENDS += "ipmi-blob-tool"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
-SRCREV = "98af2d1d8dcac298fbe793683e70f1766e88856b"
+SRCREV = "2bd7021d9adbcc63fda3d904b24e47820b735bad"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 574d03b77..ceb3c0d7a 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -33,7 +33,6 @@ DEPENDS += "sdbus++-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
-DEPENDS += "virtual/phosphor-ipmi-channel-config"
DEPENDS += "virtual/phosphor-ipmi-entity-config"
DEPENDS += "boost"
DEPENDS += "sdeventplus"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
index 3c04d82ec..1fe13d7e3 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "The IPMB bridge implements a Dbus compliant interface for \
implementing IPMB interfaces"
SRC_URI = "git://github.com/openbmc/ipmbbridge.git"
-SRCREV = "a8c77dc857fdf7fc049b975c3b3a6be11e7ea4c0"
+SRCREV = "25e85c79257723b1cb754c20299196685373ce24"
PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"