summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend1
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc-read-eeprom@.service3
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb14
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb2
8 files changed, 8 insertions, 20 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index 8f390f554..a6a8198d2 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -23,6 +23,7 @@ FILES_${PN} += "/usr/share/misc/enterprise-numbers"
do_compile_prepend() {
# copy the SRC_URI version of enterprise-numbers
# to the build dir to prevent a fetch
+ mkdir -p "${WORKDIR}/build"
cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
}
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb
index 38121e542..4d973f6e8 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_git.bb
@@ -17,7 +17,7 @@ DEPENDS += "protobuf"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
-SRCREV = "e535a736efd8ef2088c57a91c387be7800674161"
+SRCREV = "1a25e0d16ea5cb79d0942193bed92ac7dd287112"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
index 55bac7d77..7d62fc7fc 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
@@ -16,7 +16,7 @@ DEPENDS += "ipmi-blob-tool"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
-SRCREV = "9cd8f76d3a786645ba6e21e146f66f5f27a6290c"
+SRCREV = "03fd5b8b9e8fc0eb7f77c1a170fd2c0018ab9e63"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 85ccaf36a..5c8acc685 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -45,7 +45,7 @@ EXTRA_OECONF_append = " MAPPED_ADDRESS=${IPMI_FLASH_BMC_ADDRESS}"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
-SRCREV = "c8445aaa291eb720a8698765421822dea265dba7"
+SRCREV = "6f61af8fd125400d064715559cfffba92afaecf6"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} += "phosphor-ipmi-flash-bmc-prepare.target \
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc-read-eeprom@.service b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc-read-eeprom@.service
index 1486cace0..2fc30838a 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc-read-eeprom@.service
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru/obmc-read-eeprom@.service
@@ -2,9 +2,10 @@
Description=Read %I EEPROM
Wants=mapper-wait@-xyz-openbmc_project-inventory.service
After=mapper-wait@-xyz-openbmc_project-inventory.service
+StartLimitBurst=10
[Service]
-Restart=no
+Restart=on-failure
Type=oneshot
EnvironmentFile={envfiledir}/obmc/eeproms/%I
ExecStartPre={bindir}/of-name-to-eeprom.sh {envfiledir}/obmc/eeproms/%I
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc
index c0909c94c..8a2e98f91 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-host-ipmid"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid"
-SRCREV = "074f64d42d7fa7538d320ab1f0c91e641641a961"
+SRCREV = "3dc3558944da95b8b288fa1afc3aaa96d273383d"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb
deleted file mode 100644
index a9e070c7b..000000000
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Phosphor OpenBMC host IPMI to DBUS Example"
-DESCRIPTION = "Phosphor OpenBMC host IPMI to DBUS example implementation."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-RDEPENDS_${PN} += "python-subprocess python-dbus python-pygobject"
-RRECOMMENDS_${PN} += "phosphor-ipmi-host"
-
-inherit skeleton-python
-
-PROVIDES += "virtual/obmc-host-ipmi-hw"
-RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
-
-SKELETON_DIR = "pyipmitest"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
index 6b0d4da90..b622f833e 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
@@ -16,7 +16,7 @@ DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
-SRCREV = "a6ad5e161e5e5db4258b04254b19796f154b8533"
+SRCREV = "9d9b7638cb1e95989329680730ec272da786615f"
S = "${WORKDIR}/git"