summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index 8689e06c0..9fdeea0f0 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -3,9 +3,9 @@ DESCRIPTION = "Daemon to cater to triggering actions on LED groups"
PR = "r1"
PV = "1.0+git${SRCPV}"
-require ${PN}.inc
+require ${BPN}.inc
-inherit autotools pkgconfig pythonnative
+inherit autotools pkgconfig python3native
inherit obmc-phosphor-dbus-service obmc-phosphor-systemd
LED_MGR_PACKAGES = " \
@@ -20,9 +20,11 @@ DBUS_PACKAGES = "${PN}-ledmanager"
SYSTEMD_PACKAGES = "${LED_MGR_PACKAGES}"
-DEPENDS += "python-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-inflection-native"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus ${PYTHON_PN}-sdbus++-native"
DEPENDS += "systemd"
DEPENDS += "phosphor-logging"