summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb b/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
new file mode 100644
index 000000000..c5c137628
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/libmctp/libmctp_git.bb
@@ -0,0 +1,37 @@
+SUMMARY = "MCTP stack"
+DESCRIPTION = "MCTP library implementing the MCTP base specification"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit systemd
+inherit autotools pkgconfig
+
+HOMEPAGE = "https://github.com/openbmc/libmctp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
+SRC_URI = "git://github.com/openbmc/libmctp \
+ file://default"
+SRCREV = "ae59f4fe3a3ceaf52a682ada2a2b54855fad2408"
+
+DEPENDS += "autoconf-archive-native \
+ systemd \
+ "
+
+SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
+ mctp-demux.socket \
+ "
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
+ --without-systemdsystemunitdir,systemd"
+
+PACKAGECONFIG[astlpc-raw-kcs] = "--enable-astlpc-raw-kcs,--disable-astlpc-raw-kcs,udev,udev"
+
+CONFFILES:${PN} = "${sysconfdir}/default/mctp"
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
+}
+
+S = "${WORKDIR}/git"