summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index 6d95406bc..7844a44ef 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -8,7 +8,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
inherit obmc-phosphor-dbus-service
inherit phosphor-logging
inherit phosphor-dbus-yaml
@@ -18,7 +18,8 @@ DEPENDS += "systemd"
DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "${PYTHON_PN}-pyyaml-native"
DEPENDS += "${PYTHON_PN}-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += "sdbusplus"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "virtual/phosphor-logging-callouts"
DEPENDS += "phosphor-logging-error-logs-native"
@@ -55,7 +56,7 @@ FILES_phosphor-rsyslog-config += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-logging"
-SRCREV = "bebeb948177220985f6ede067b9c8f2ab30401dd"
+SRCREV = "182071455a82b22e8111217d624c25f4c86dce43"
S = "${WORKDIR}/git"
@@ -63,7 +64,7 @@ S = "${WORKDIR}/git"
# as they will not be available in host machine
DEPENDS_remove_class-native = " \
virtual/phosphor-logging-callouts \
- sdbus++ \
+ sdbusplus \
systemd \
libcereal \
sdeventplus \
@@ -73,7 +74,7 @@ DEPENDS_remove_class-native = " \
# as they will not be available in host machine
DEPENDS_remove_class-nativesdk = " \
virtual/phosphor-logging-callouts \
- sdbus++-native \
+ sdbusplus \
libcereal \
systemd \
phosphor-dbus-interfaces \