summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
new file mode 100644
index 000000000..1930388ed
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
+DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
+PR = "r1"
+
+S = "${WORKDIR}/scripts"
+
+inherit obmc-phosphor-license
+inherit native
+inherit perlnative
+inherit cpan-base
+inherit mrw-rev
+
+DEPENDS += "libxml-simple-perl-native json-perl-native"
+
+SRC_URI += "${MRW_API_SRC_URI}"
+SRCREV = "${MRW_API_SRCREV}"
+
+do_install() {
+ install -d ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+ install -m 0755 Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+}