summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 72f49a5bc..630dc6bcd 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -8,9 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
inherit autotools pkgconfig
inherit python3native
-inherit phosphor-networkd-rev
inherit systemd
+SRC_URI += "git://github.com/openbmc/phosphor-networkd"
+SRCREV = "de433b74ec5bce22043ea44c55e83d9be3dc5372"
DEPENDS += "systemd"
DEPENDS += "autoconf-archive-native"
@@ -22,10 +23,14 @@ DEPENDS += "libnl"
DEPENDS += "stdplus"
DEPENDS += "nlohmann-json"
-PACKAGECONFIG ??= "uboot-env"
+PACKAGECONFIG ??= "uboot-env default-link-local-autoconf default-ipv6-accept-ra"
UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
PACKAGECONFIG[uboot-env] = "--with-uboot-env,--without-uboot-env,,${UBOOT_ENV_RDEPENDS}"
+PACKAGECONFIG[default-link-local-autoconf] = "--enable-link-local-autoconfiguration,--disable-link-local-autoconfiguration,,"
+PACKAGECONFIG[default-ipv6-accept-ra] = "--enable-ipv6-accept-ra,--disable-ipv6-accept-ra,,"
+PACKAGECONFIG[nic-ethtool] = "--enable-nic-ethtool,--disable-nic-ethtool,,"
+PACKAGECONFIG[sync-mac] = "--enable-sync-mac,--disable-sync-mac,,"
S = "${WORKDIR}/git"