summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
new file mode 100644
index 000000000..aa6addbb9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Network DBUS object"
+DESCRIPTION = "Network DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit phosphor-networkd-rev
+inherit systemd
+
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "libnl"
+
+S = "${WORKDIR}/git"
+
+SERVICE_FILE = "xyz.openbmc_project.Network.service"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+
+EXTRA_OECONF = " \
+ SYSTEMD_TARGET="multi-user.target" \
+"