summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
new file mode 100644
index 000000000..c09e5dd02
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "PLDM Stack"
+DESCRIPTION = "Implementation of the PLDM specifications"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson pkgconfig
+
+require pldm.inc
+
+DEPENDS += "systemd"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "nlohmann-json"
+DEPENDS += "boost"
+DEPENDS += "cli11"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ -Doem-ibm=disabled \
+ "