summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index bcf1bed23..4c9cbc983 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -28,22 +28,22 @@ EXTRA_OEMESON = " \
# Install pldmSoftPowerOff.service in correct targets
pkg_postinst:${PN} () {
- mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
- LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
- mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
- LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
}
pkg_prerm:${PN} () {
- LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
rm $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
rm $LINK
}