summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 44e42fbdb..bcf1bed23 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -17,8 +17,8 @@ DEPENDS += "cli11"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "pldmd.service"
-SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service"
+SYSTEMD_SERVICE:${PN} += "pldmd.service"
+SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
EXTRA_OEMESON = " \
-Dtests=disabled \
@@ -26,7 +26,7 @@ EXTRA_OEMESON = " \
"
# Install pldmSoftPowerOff.service in correct targets
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
@@ -39,7 +39,7 @@ pkg_postinst_${PN} () {
ln -s $TARGET $LINK
}
-pkg_prerm_${PN} () {
+pkg_prerm:${PN} () {
LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
rm $LINK