summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index d8dcd0d2c..1c07ad59d 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -4,6 +4,7 @@ PR = "r1"
PV = "1.0+git${SRCPV}"
inherit meson pkgconfig
+inherit systemd
require pldm.inc
@@ -15,7 +16,33 @@ DEPENDS += "cli11"
S = "${WORKDIR}/git"
+SYSTEMD_SERVICE_${PN} += "pldmd.service"
+SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service"
+
EXTRA_OEMESON = " \
-Dtests=disabled \
-Doem-ibm=disabled \
"
+
+# Install pldmSoftPowerOff.service in correct targets
+pkg_postinst_${PN} () {
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN} () {
+
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ rm $LINK
+}