summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb b/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
index 5642f1601..eb8e39cd0 100644
--- a/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
+++ b/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
@@ -4,18 +4,18 @@ inherit update-alternatives
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
+RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
SRC_URI += "file://init"
-FILES_${PN} += "${base_sbindir}/init"
+FILES:${PN} += "${base_sbindir}/init"
do_install() {
install -d ${D}/${base_sbindir}
install -m 0755 ${WORKDIR}/init ${D}/${base_sbindir}/preinit-mounts
}
-ALTERNATIVE_${PN} = "init"
+ALTERNATIVE:${PN} = "init"
ALTERNATIVE_TARGET[init] = "${base_sbindir}/preinit-mounts"
ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"