summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
index de720730a..4b165f86b 100644
--- a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -9,7 +9,7 @@ DESCRIPTION = "Utility to write IPMI SEL records to the journal"
# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
# Monitors and logs SEL records for threshold sensor events
-inherit cmake systemd
+inherit meson systemd
S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
@@ -19,19 +19,19 @@ DEPENDS += " \
boost \
sdbusplus \
systemd \
- phosphor-logging \
"
SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
-SRCREV = "e9da2599f10f1b696f61c97f8c8036acfde05e18"
+SRCREV = "a138ebd3c759f95c53d61170c05e69bf31718114"
PV = "0.1+git${SRCPV}"
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
PACKAGECONFIG ??= ""
-PACKAGECONFIG[log-threshold] = "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON,-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=OFF,"
-PACKAGECONFIG[log-pulse] = "-DREDFISH_LOG_MONITOR_PULSE_EVENTS=ON,-DREDFISH_LOG_MONITOR_PULSE_EVENTS=OFF,"
-PACKAGECONFIG[log-watchdog] = "-DSEL_LOGGER_MONITOR_WATCHDOG_EVENTS=ON,-DSEL_LOGGER_MONITOR_WATCHDOG_EVENTS=OFF,"
-PACKAGECONFIG[log-alarm] = "-DSEL_LOGGER_MONITOR_THRESHOLD_ALARM_EVENTS=ON,-DSEL_LOGGER_MONITOR_THRESHOLD_ALARM_EVENTS=OFF,"
-PACKAGECONFIG[send-to-logger] = "-DSEL_LOGGER_SEND_TO_LOGGING_SERVICE=ON,-DSEL_LOGGER_SEND_TO_LOGGING_SERVICE=OFF,phosphor-logging"
+PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
+PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
+PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
+PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
+PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
+PACKAGECONFIG[clears-sel] = "-Dclears-sel=true,-Dclears-sel=false"