summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
index 9be702886..de720730a 100644
--- a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -15,7 +15,12 @@ S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-DEPENDS += "systemd sdbusplus boost phosphor-ipmi-host"
+DEPENDS += " \
+ boost \
+ sdbusplus \
+ systemd \
+ phosphor-logging \
+ "
SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
SRCREV = "e9da2599f10f1b696f61c97f8c8036acfde05e18"
@@ -23,3 +28,10 @@ SRCREV = "e9da2599f10f1b696f61c97f8c8036acfde05e18"
PV = "0.1+git${SRCPV}"
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[log-threshold] = "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON,-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=OFF,"
+PACKAGECONFIG[log-pulse] = "-DREDFISH_LOG_MONITOR_PULSE_EVENTS=ON,-DREDFISH_LOG_MONITOR_PULSE_EVENTS=OFF,"
+PACKAGECONFIG[log-watchdog] = "-DSEL_LOGGER_MONITOR_WATCHDOG_EVENTS=ON,-DSEL_LOGGER_MONITOR_WATCHDOG_EVENTS=OFF,"
+PACKAGECONFIG[log-alarm] = "-DSEL_LOGGER_MONITOR_THRESHOLD_ALARM_EVENTS=ON,-DSEL_LOGGER_MONITOR_THRESHOLD_ALARM_EVENTS=OFF,"
+PACKAGECONFIG[send-to-logger] = "-DSEL_LOGGER_SEND_TO_LOGGING_SERVICE=ON,-DSEL_LOGGER_SEND_TO_LOGGING_SERVICE=OFF,phosphor-logging"