summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sel-logger
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sel-logger')
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
new file mode 100644
index 000000000..7aa372bf8
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Journal IPMI SEL Logger"
+DESCRIPTION = "Utility to write IPMI SEL records to the journal"
+
+# SEL Logger has the ability to monitor and automatically log SEL records for
+# various types of events, but this is disabled by default. The following
+# flags can be set in a .bbappend to enable specific types of event
+# monitoring:
+#
+# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
+# Monitors and logs SEL records for threshold sensor events
+
+inherit cmake systemd
+S = "${WORKDIR}/git/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS += "systemd sdbusplus boost phosphor-ipmi-host"
+
+SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
+SRCREV = "5e049d37ae975868062164279a2dbcd290fd1af5"
+
+PV = "0.1+git${SRCPV}"
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service"