summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb
new file mode 100644
index 000000000..3ba8c4a7a
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "NVMe Drive Manager"
+DESCRIPTION = "Daemon to monitor and report the status of NVMe drives"
+HOMEPAGE = "https://github.com/openbmc/phosphor-nvme"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit meson pkgconfig
+inherit systemd
+
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-logging"
+DEPENDS += "nlohmann-json"
+
+SRC_URI = "git://github.com/openbmc/phosphor-nvme.git;protocol=git"
+SRCREV = "e41b2e4c6c579f451b8d01ffff7abc46f0f7c6b2"
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.nvme.manager.service"