summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
new file mode 100644
index 000000000..3a25890b9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Virtual Sensors"
+DESCRIPTION = "virtual sensors created from existing sensors and config data"
+HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
+
+inherit meson pkgconfig
+inherit systemd
+
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-logging"
+DEPENDS += "nlohmann-json"
+DEPENDS += "exprtk"
+
+SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
+SRCREV = "f8db722567d16b93bde7d37d3d7a6e83d08373aa"
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "phosphor-virtual-sensor.service"