summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
index 59692ecb8..85191c636 100644
--- a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
@@ -14,6 +14,20 @@ SKELETON_DIR = "libopenbmc_intf"
SRC_URI += "file://gpio_defs.json"
+# Users of libopenbmc_intf use custom makefiles that do not
+# support the proper library version detection and linking.
+# Because of that, a link must be created within the
+# rootfs for applicaitons to use this library.
+# This next line tells bitbake to skip the check which
+# ensures no links are put in the rootfs
+INSANE_SKIP_${PN} += "dev-so"
+
+# Ensure the library is not in the dev package
+FILES_SOLIBSDEV = ""
+
+# Now add the link to the production package
+FILES_${PN} += "${libdir}/libopenbmc_intf.so"
+
do_install() {
oe_runmake install DESTDIR=${D}