summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/state
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/state')
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb12
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb2
2 files changed, 7 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
index d5d81f8ba..483b8fe03 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
@@ -4,7 +4,7 @@ interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
in a file under /var/lib for history."
SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
-SRCREV = "9ce5a645f50c0ab94e582abbf95474f636aba678"
+SRCREV = "f5e52db77cb580b2a6e9b95d06e26bfd185627d9"
S = "${WORKDIR}/git"
@@ -13,14 +13,15 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit cmake pkgconfig systemd
+inherit meson pkgconfig systemd
def get_service(d):
+ service_list = "xyz.openbmc_project.State.Boot.PostCode.service xyz.openbmc_project.State.Boot.PostCode@.service "
if(d.getVar('OBMC_HOST_INSTANCES') == '0'):
- return "xyz.openbmc_project.State.Boot.PostCode.service"
+ return service_list
else:
- return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
+ return service_list+" ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
@@ -28,7 +29,6 @@ DEPENDS += " \
sdbusplus \
phosphor-dbus-interfaces \
phosphor-logging \
+ libcereal \
"
-FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
-FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 5f76096ec..c9b14dc93 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -187,6 +187,6 @@ SYSTEMD_LINK:${PN}-obmc-targets += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERRO
SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
-SRCREV = "1e89e62283ea037823319244fc2de6c351c18538"
+SRCREV = "68a8c31d820718588a583625e88ba2626ef64526"
S = "${WORKDIR}/git"