summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
new file mode 100644
index 000000000..feff0045e
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Telemetry service"
+DESCRIPTION = "Middleware between Redfish Telemetry Service and dbus-sensors"
+HOMEPAGE = "https://github.com/openbmc/telemetry"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "git://github.com/openbmc/telemetry"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "0e29f4392264a9646834583ddd5eaadc25fab20b"
+
+S = "${WORKDIR}/git"
+
+inherit meson
+inherit systemd
+
+DEPENDS = "boost \
+ gtest \
+ nlohmann-json \
+ phosphor-logging \
+ sdbusplus \
+ systemd"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Telemetry.service"
+EXTRA_OEMESON = "-Dbuildtest=false"
+