summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index 3059a55af..e55072303 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -30,11 +30,13 @@ export CXXFLAGS = "${BUILD_CXXFLAGS}"
FILES:${PN} += "${datadir}/www/*"
+EXTRA_OENPM ?= ""
+
do_compile () {
cd ${S}
rm -rf node_modules
npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
- npm run build
+ npm run build ${EXTRA_OENPM}
}
do_install () {