summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init/mmc-init.sh12
2 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
index 0c7a88cd9..aa55d1be9 100644
--- a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
@@ -8,8 +8,10 @@ PR = "r1"
inherit allarch
RDEPENDS_${PN} += " \
+ ${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'} \
${VIRTUAL-RUNTIME_base-utils} \
e2fsprogs-e2fsck \
+ e2fsprogs-mke2fs \
gptfdisk \
parted \
udev \
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init/mmc-init.sh b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init/mmc-init.sh
index 3fad5e6fa..575b7605a 100644
--- a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init/mmc-init.sh
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init/mmc-init.sh
@@ -49,6 +49,18 @@ if ! mount /dev/disk/by-partlabel/"$(get_root)" $rodir -t ext4 -o ro; then
fi
rwfsdev="/dev/disk/by-partlabel/rwfs"
+mkdir -p /var/lock
+if test $(fw_printenv -n rwreset) = "true"; then
+ echo "Factory reset requested."
+ if ! mkfs.ext4 -F "${rwfsdev}"; then
+ echo "Reformat for factory reset failed."
+ /bin/sh
+ else
+ fw_setenv rwreset
+ echo "Formatting of rwfs is complete."
+ fi
+fi
+
fsck.ext4 -p "${rwfsdev}"
if ! mount "${rwfsdev}" $rodir/var -t ext4 -o rw; then
/bin/sh