summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend')
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend12
1 files changed, 4 insertions, 8 deletions
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index cda8e0b51..16add36d8 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -1,17 +1,13 @@
-
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://rngd.service"
+SRC_URI += "file://10-nice.conf"
inherit systemd
-SYSTEMD_SERVICE_${PN} = "rngd.service"
+FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d"
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/rngd.service ${D}${systemd_unitdir}/system
- sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/rngd.service
+ install -d ${D}${systemd_unitdir}/system/rngd.service.d
+ install -m 644 ${WORKDIR}/10-nice.conf ${D}${systemd_unitdir}/system/rngd.service.d
fi
}
-