summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb')
-rwxr-xr-xmeta-phosphor/recipes-x86/chassis/x86-power-control_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
index 16926c663..9f5810565 100755
--- a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
+++ b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
@@ -20,9 +20,9 @@ def get_service(d):
else:
return " ".join(["xyz.openbmc_project.Chassis.Control.Power@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
-SYSTEMD_SERVICE_${PN} = "${@get_service(d)}"
+SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
-SYSTEMD_SERVICE_${PN} += "chassis-system-reset.service \
+SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \
chassis-system-reset.target"
DEPENDS += " \
@@ -33,4 +33,4 @@ DEPENDS += " \
sdbusplus \
phosphor-logging \
"
-FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" \ No newline at end of file
+FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" \ No newline at end of file