summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-x86')
-rwxr-xr-xmeta-phosphor/recipes-x86/chassis/x86-power-control_git.bb6
-rw-r--r--meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
index 16926c663..9f5810565 100755
--- a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
+++ b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
@@ -20,9 +20,9 @@ def get_service(d):
else:
return " ".join(["xyz.openbmc_project.Chassis.Control.Power@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
-SYSTEMD_SERVICE_${PN} = "${@get_service(d)}"
+SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
-SYSTEMD_SERVICE_${PN} += "chassis-system-reset.service \
+SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \
chassis-system-reset.target"
DEPENDS += " \
@@ -33,4 +33,4 @@ DEPENDS += " \
sdbusplus \
phosphor-logging \
"
-FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" \ No newline at end of file
+FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" \ No newline at end of file
diff --git a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
index 6716d9a22..6cc4fd8d4 100644
--- a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
+++ b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
@@ -15,6 +15,6 @@ SRCREV = "6f55203b70316baec228073abcd581b64985af93"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.PCIe.service"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.PCIe.service"
EXTRA_OECMAKE = "-DYOCTO=1"