summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-x86')
-rwxr-xr-xmeta-phosphor/recipes-x86/chassis/x86-power-control_git.bb4
-rw-r--r--meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb20
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
index cb1daba0b..88c01f4e7 100755
--- a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
+++ b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Chassis Power Control service for Intel based platforms"
DESCRIPTION = "Chassis Power Control service for Intel based platforms"
SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
-SRCREV = "b0c613aa889136610811d5f44a172081731db216"
+SRCREV = "01a77864f49088bac80474587a123d1f152f2b26"
PV = "1.0+git${SRCPV}"
@@ -12,6 +12,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit cmake systemd
+inherit obmc-phosphor-dbus-service
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service \
chassis-system-reset.service \
@@ -21,6 +22,7 @@ DEPENDS += " \
boost \
i2c-tools \
libgpiod \
+ nlohmann-json \
sdbusplus \
phosphor-logging \
"
diff --git a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
new file mode 100644
index 000000000..f6ef79d46
--- /dev/null
+++ b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "PECI PCIe"
+DESCRIPTION = "Gathers PCIe information using PECI \
+and provides it on D-Bus"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake systemd
+
+SRC_URI = "git://github.com/openbmc/peci-pcie"
+
+DEPENDS = "boost sdbusplus libpeci"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "bce86a63643e1d7cdf6d42e143738013ee47a8da"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.PCIe.service"
+
+EXTRA_OECMAKE = "-DYOCTO=1"