summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/image_types_phosphor.bbclass75
-rw-r--r--meta-phosphor/classes/mrw-xml.bbclass2
-rw-r--r--meta-phosphor/classes/phosphor-networkd-rev.bbclass2
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf3
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend11
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm.inc5
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb22
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb2
23 files changed, 123 insertions, 29 deletions
diff --git a/meta-phosphor/classes/image_types_phosphor.bbclass b/meta-phosphor/classes/image_types_phosphor.bbclass
index f7742c85e..23ff3475c 100644
--- a/meta-phosphor/classes/image_types_phosphor.bbclass
+++ b/meta-phosphor/classes/image_types_phosphor.bbclass
@@ -16,15 +16,18 @@ IMAGE_BASETYPE ?= "squashfs-xz"
OVERLAY_BASETYPE ?= "jffs2"
FLASH_UBI_BASETYPE ?= "${IMAGE_BASETYPE}"
FLASH_UBI_OVERLAY_BASETYPE ?= "ubifs"
+FLASH_EXT4_BASETYPE ?= "ext4"
+FLASH_EXT4_OVERLAY_BASETYPE ?= "ext4"
-IMAGE_TYPES += "mtd-static mtd-static-alltar mtd-static-tar mtd-ubi mtd-ubi-tar"
+IMAGE_TYPES += "mtd-static mtd-static-alltar mtd-static-tar mtd-ubi mtd-ubi-tar mmc-ext4-tar"
IMAGE_TYPEDEP_mtd-static = "${IMAGE_BASETYPE}"
IMAGE_TYPEDEP_mtd-static-tar = "${IMAGE_BASETYPE}"
IMAGE_TYPEDEP_mtd-static-alltar = "mtd-static"
IMAGE_TYPEDEP_mtd-ubi = "${FLASH_UBI_BASETYPE}"
IMAGE_TYPEDEP_mtd-ubi-tar = "${FLASH_UBI_BASETYPE}"
-IMAGE_TYPES_MASKED += "mtd-static mtd-static-alltar mtd-static-tar mtd-ubi mtd-ubi-tar"
+IMAGE_TYPEDEP_mmc-ext4-tar = "${FLASH_EXT4_BASETYPE}"
+IMAGE_TYPES_MASKED += "mtd-static mtd-static-alltar mtd-static-tar mtd-ubi mtd-ubi-tar mmc-ext4-tar"
# Flash characteristics in KB unless otherwise noted
DISTROOVERRIDES .= ":flash-${FLASH_SIZE}"
@@ -77,21 +80,33 @@ python() {
# Instead, prefix the overlay override value with 'rwfs-' to avoid collisions.
DISTROOVERRIDES .= ":static-rwfs-${OVERLAY_BASETYPE}"
DISTROOVERRIDES .= ":ubi-rwfs-${FLASH_UBI_OVERLAY_BASETYPE}"
+DISTROOVERRIDES .= ":mmc-rwfs-${FLASH_EXT4_OVERLAY_BASETYPE}"
JFFS2_RWFS_CMD = "mkfs.jffs2 --root=jffs2 --faketime --output=${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.jffs2"
UBIFS_RWFS_CMD = "mkfs.ubifs -r ubifs -c ${FLASH_UBI_RWFS_LEBS} -m ${FLASH_PAGE_SIZE} -e ${FLASH_LEB_SIZE} ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.ubifs"
+EXT4_RWFS_CMD = "mkfs.ext4 -F ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.rwfs.ext4"
FLASH_STATIC_RWFS_CMD_static-rwfs-jffs2 = "${JFFS2_RWFS_CMD}"
FLASH_UBI_RWFS_CMD_ubi-rwfs-jffs2 = "${JFFS2_RWFS_CMD}"
FLASH_UBI_RWFS_CMD_ubi-rwfs-ubifs = "${UBIFS_RWFS_CMD}"
+FLASH_EXT4_RWFS_CMD_mmc-rwfs-ext4 = "${EXT4_RWFS_CMD}"
-mk_nor_image() {
+mk_empty_image() {
image_dst="$1"
image_size_kb=$2
dd if=/dev/zero bs=1k count=$image_size_kb \
| tr '\000' '\377' > $image_dst
}
+clean_rwfs() {
+ type=$1
+ shift
+
+ rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.$type
+ rm -rf $type
+ mkdir $type
+}
+
make_rwfs() {
type=$1
cmd=$2
@@ -99,14 +114,13 @@ make_rwfs() {
shift
opts="$@"
- rm -f ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.$type
- rm -rf $type
- mkdir $type
+ mkdir -p $type
$cmd $opts
}
do_generate_rwfs_static() {
+ clean_rwfs ${OVERLAY_BASETYPE}
make_rwfs ${OVERLAY_BASETYPE} "${FLASH_STATIC_RWFS_CMD}" ${OVERLAY_MKFS_OPTS}
}
do_generate_rwfs_static[dirs] = " ${S}/static"
@@ -115,6 +129,7 @@ do_generate_rwfs_static[depends] += " \
"
do_generate_rwfs_ubi() {
+ clean_rwfs ${FLASH_UBI_OVERLAY_BASETYPE}
make_rwfs ${FLASH_UBI_OVERLAY_BASETYPE} "${FLASH_UBI_RWFS_CMD}"
}
do_generate_rwfs_ubi[dirs] = " ${S}/ubi"
@@ -122,6 +137,16 @@ do_generate_rwfs_ubi[depends] += " \
mtd-utils-native:do_populate_sysroot \
"
+do_generate_rwfs_ext4() {
+ clean_rwfs rwfs.${FLASH_EXT4_OVERLAY_BASETYPE}
+ mk_empty_image ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.rwfs.ext4 1024
+ make_rwfs ${FLASH_EXT4_OVERLAY_BASETYPE} "${FLASH_EXT4_RWFS_CMD}" ${OVERLAY_MKFS_OPTS}
+}
+do_generate_rwfs_ext4[dirs] = " ${S}/ext4"
+do_generate_rwfs_ext4[depends] += " \
+ e2fsprogs-native:do_populate_sysroot \
+ "
+
add_volume() {
config_file=$1
vol_id=$2
@@ -170,7 +195,7 @@ do_make_ubi() {
ubinize -p ${FLASH_PEB_SIZE}KiB -m ${FLASH_PAGE_SIZE} -o ubi-img $cfg
# Concatenate the uboot and ubi partitions
- mk_nor_image ${IMGDEPLOYDIR}/${IMAGE_NAME}.ubi.mtd ${FLASH_SIZE}
+ mk_empty_image ${IMGDEPLOYDIR}/${IMAGE_NAME}.ubi.mtd ${FLASH_SIZE}
dd bs=1k conv=notrunc seek=${FLASH_UBOOT_OFFSET} \
if=${DEPLOY_DIR_IMAGE}/u-boot.${UBOOT_SUFFIX} \
of=${IMGDEPLOYDIR}/${IMAGE_NAME}.ubi.mtd
@@ -191,7 +216,7 @@ do_make_ubi[depends] += " \
do_mk_static_nor_image() {
# Assemble the flash image
- mk_nor_image ${IMGDEPLOYDIR}/${IMAGE_NAME}.static.mtd ${FLASH_SIZE}
+ mk_empty_image ${IMGDEPLOYDIR}/${IMAGE_NAME}.static.mtd ${FLASH_SIZE}
}
python do_generate_static() {
@@ -314,11 +339,11 @@ make_tar_of_images() {
extra_files="$@"
# Create the tar archive
- tar -h -cvf ${IMGDEPLOYDIR}/${IMAGE_NAME}.$type.mtd.tar \
+ tar -h -cvf ${IMGDEPLOYDIR}/${IMAGE_NAME}.$type.tar \
image-u-boot image-kernel image-rofs image-rwfs $extra_files
cd ${IMGDEPLOYDIR}
- ln -sf ${IMAGE_NAME}.$type.mtd.tar ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.$type.mtd.tar
+ ln -sf ${IMAGE_NAME}.$type.tar ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.$type.tar
}
do_generate_static_tar() {
@@ -326,7 +351,7 @@ do_generate_static_tar() {
ln -sf ${S}/publickey publickey
make_image_links ${OVERLAY_BASETYPE} ${IMAGE_BASETYPE}
make_signatures image-u-boot image-kernel image-rofs image-rwfs MANIFEST publickey
- make_tar_of_images static MANIFEST publickey ${signature_files}
+ make_tar_of_images static.mtd MANIFEST publickey ${signature_files}
# Maintain non-standard legacy link.
cd ${IMGDEPLOYDIR}
@@ -348,7 +373,7 @@ do_generate_ubi_tar() {
ln -sf ${S}/publickey publickey
make_image_links ${FLASH_UBI_OVERLAY_BASETYPE} ${FLASH_UBI_BASETYPE}
make_signatures image-u-boot image-kernel image-rofs image-rwfs MANIFEST publickey
- make_tar_of_images ubi MANIFEST publickey ${signature_files}
+ make_tar_of_images ubi.mtd MANIFEST publickey ${signature_files}
}
do_generate_ubi_tar[dirs] = " ${S}/ubi"
do_generate_ubi_tar[depends] += " \
@@ -360,6 +385,23 @@ do_generate_ubi_tar[depends] += " \
${PN}:do_copy_signing_pubkey \
"
+do_generate_ext4_tar() {
+ ln -sf ${S}/MANIFEST MANIFEST
+ ln -sf ${S}/publickey publickey
+ make_image_links rwfs.${FLASH_EXT4_OVERLAY_BASETYPE} ${FLASH_EXT4_BASETYPE}
+ make_signatures image-u-boot image-kernel image-rofs image-rwfs MANIFEST publickey
+ make_tar_of_images ext4.mmc MANIFEST publickey ${signature_files}
+}
+do_generate_ext4_tar[dirs] = " ${S}/ext4"
+do_generate_ext4_tar[depends] += " \
+ ${PN}:do_image_${FLASH_EXT4_BASETYPE} \
+ virtual/kernel:do_deploy \
+ u-boot:do_populate_sysroot \
+ openssl-native:do_populate_sysroot \
+ ${SIGNING_KEY_DEPENDS} \
+ ${PN}:do_copy_signing_pubkey \
+ "
+
def get_pubkey_basedir(d):
return os.path.join(
d.getVar('STAGING_DIR_TARGET', True),
@@ -377,11 +419,13 @@ def get_pubkey_path(d):
python do_generate_phosphor_manifest() {
version = do_get_version(d)
+ target_machine = d.getVar('MACHINE', True)
with open('MANIFEST', 'w') as fd:
fd.write('purpose=xyz.openbmc_project.Software.Version.VersionPurpose.BMC\n')
fd.write('version={}\n'.format(version.strip('"')))
fd.write('KeyType={}\n'.format(get_pubkey_type(d)))
fd.write('HashType=RSA-SHA256\n')
+ fd.write('MachineName={}\n'.format(target_machine))
}
do_generate_phosphor_manifest[dirs] = "${S}"
do_generate_phosphor_manifest[depends] += " \
@@ -404,6 +448,7 @@ addtask copy_signing_pubkey after do_rootfs
addtask generate_phosphor_manifest after do_rootfs
addtask generate_rwfs_static after do_rootfs
addtask generate_rwfs_ubi after do_rootfs
+addtask generate_rwfs_ext4 after do_rootfs
python() {
types = d.getVar('IMAGE_FSTYPES', True).split()
@@ -434,4 +479,10 @@ python() {
'do_generate_ubi_tar',
'do_image_complete',
'do_generate_rwfs_ubi do_generate_phosphor_manifest', d)
+
+ if 'mmc-ext4-tar' in types:
+ bb.build.addtask(
+ 'do_generate_ext4_tar',
+ 'do_image_complete',
+ 'do_generate_rwfs_ext4 do_generate_phosphor_manifest', d)
}
diff --git a/meta-phosphor/classes/mrw-xml.bbclass b/meta-phosphor/classes/mrw-xml.bbclass
index 5a9c773ae..8876de706 100644
--- a/meta-phosphor/classes/mrw-xml.bbclass
+++ b/meta-phosphor/classes/mrw-xml.bbclass
@@ -1,2 +1,4 @@
MRW_XML ??= "${MACHINE}.xml"
mrw_datadir = "${datadir}/obmc-mrw"
+SKIP_BROKEN_MRW ?= "0"
+EXTRA_MRW_SCRIPT_ARGS = "${@bb.utils.contains("SKIP_BROKEN_MRW", "0", "", "--skip-broken-mrw", d)}"
diff --git a/meta-phosphor/classes/phosphor-networkd-rev.bbclass b/meta-phosphor/classes/phosphor-networkd-rev.bbclass
index 57878ddac..1c8a01a6c 100644
--- a/meta-phosphor/classes/phosphor-networkd-rev.bbclass
+++ b/meta-phosphor/classes/phosphor-networkd-rev.bbclass
@@ -1,2 +1,2 @@
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
-SRCREV = "046b2a0b3707621a3828da1318b628bcc31d1aaa"
+SRCREV = "cb42fe26febc9e457a9c4279278bd8c85f60851a"
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf b/meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf
new file mode 100644
index 000000000..9a594c6e1
--- /dev/null
+++ b/meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf
@@ -0,0 +1,3 @@
+[Service]
+ExecStartPre=/bin/sh -c "grep -q avahi: /etc/group || /usr/sbin/addgroup --system avahi"
+ExecStartPre=/bin/sh -c "grep -q avahi: /etc/passwd || /usr/sbin/adduser --system --no-create-home --ingroup avahi avahi"
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
new file mode 100644
index 000000000..ee15899fa
--- /dev/null
+++ b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/avahi-daemon:"
+
+SRC_URI += "file://avahi-daemon-override.conf"
+
+FILES_avahi-daemon_append += "${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
+
+do_install_append() {
+
+ install -m 644 -D ${WORKDIR}/avahi-daemon-override.conf \
+ ${D}${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf
+}
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index 765ae6f71..6e6fd1eaf 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Entity Manager provides d-bus configuration data \
and configures system sensors"
SRC_URI = "git://github.com/openbmc/entity-manager.git"
-SRCREV = "ce80db74ee4eceef3dcd236c74ba4d2aaaf76bda"
+SRCREV = "978fcadadc8320ff5356ed1a5dc25e3284e3745f"
PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 84d9cdf9b..d34d1ca54 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -14,7 +14,7 @@ DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbus++-native"
SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
-SRCREV = "7aa705a9356c16d3540943a0436ea09c0fa61ab2"
+SRCREV = "9cb4a711cff999b373cf98b44cc18b9001c1395a"
DEPENDS_remove_class-native = "sdbus++-native"
DEPENDS_remove_class-nativesdk = "sdbus++-native"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
index faac52ce5..90fa3ac40 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
-SRCREV = "91e14a58027e8084eb114e0afce6081a6a95a478"
+SRCREV = "22bf9008271a2f084a3369f7550a4b66305649dd"
inherit autotools \
pkgconfig \
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc b/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
index 0c6092a9e..4b3eaf4af 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-fan-presence"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-fan-presence"
-SRCREV = "301ec595f551393ebe0624e64b4b40bfc3bc1fcf"
+SRCREV = "799cdf74d50c6ced0e1a1afcef1fe7fc50e71da8"
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc
index 17a9e385b..30b8078d9 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"
-SRCREV = "85c356f76fe07db3c1253c48f5b35c5811a15c07"
+SRCREV = "5a7363b4cfdf995a6bebb80b6fe1cd3514c593a6"
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index dab8e0dd3..b81e580cf 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
SRC_URI = "git://github.com/openbmc/bmcweb.git"
PV = "1.0+git${SRCPV}"
-SRCREV = "a3268f98f308ca7c8660b1ace44d5b9a40be204b"
+SRCREV = "717794d5465c54e07a1247db9e9d7ec68b0d6cc6"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager.inc b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager.inc
index d046e4a8d..cee138864 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager.inc
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-inventory-manager"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/openbmc/phosphor-inventory-manager"
-SRCREV = "ded627c42f5e5319e3704fff742a0227c05f00a9" \ No newline at end of file
+SRCREV = "bbacd2326f84fb821c634e3cdfa78c2c7fedc0cf" \ No newline at end of file
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb b/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
index bb16749a9..f871088df 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmi-blob-tool_git.bb
@@ -14,4 +14,4 @@ EXTRA_OECONF = "--disable-tests"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/ipmi-blob-tool"
-SRCREV = "958f1ce952849300ebfd30cc04ce86937d3bc718"
+SRCREV = "00f39b84037a840a1b169a8017be75ac6636cb6f"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 09bf1029b..feea0ec32 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -44,7 +44,7 @@ EXTRA_OECONF_append = " MAPPED_ADDRESS=${IPMI_FLASH_BMC_ADDRESS}"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
-SRCREV = "6749ba1c93c9b4f65c9ef7791987fc2f98bc15d1"
+SRCREV = "a9f674c5ba0436382ee839f463e2e4d120272de7"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} += "phosphor-ipmi-flash-bmc-prepare.target \
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
index f6b63dfe3..5869bb7c2 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
@@ -16,7 +16,7 @@ DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
-SRCREV = "ddba9d15af607274462fc3372b3d72393d03899a"
+SRCREV = "dafe36444fa438030fdf27089b0e94d8d88411dc"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index aeae1ff35..6728b0777 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -54,7 +54,7 @@ FILES_phosphor-rsyslog-config += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-logging"
-SRCREV = "14d671fa2311144fe43047486c4938e9c461ce24"
+SRCREV = "31eed996da81cf6e35e7ddd035aa8088be230218"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb b/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
index a810faf58..b33df921d 100644
--- a/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
+++ b/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
@@ -19,7 +19,7 @@ SRC_URI += "git://github.com/openbmc/mboxbridge.git"
SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
-SRCREV="7e3f20d02f6555d082cdc320790ac8fd9976effb"
+SRCREV="0acc669979cc5b1b66c2c4e5d975c60779bedd81"
PROVIDES += "mboxctl"
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm.inc b/meta-phosphor/recipes-phosphor/pldm/pldm.inc
new file mode 100644
index 000000000..149d51ef9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm.inc
@@ -0,0 +1,5 @@
+HOMEPAGE = "https://github.com/openbmc/pldm"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+SRC_URI = "git://github.com/openbmc/pldm"
+SRCREV = "497665acdb655e965545becf97c2ccf41545ac6f"
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
new file mode 100644
index 000000000..c09e5dd02
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "PLDM Stack"
+DESCRIPTION = "Implementation of the PLDM specifications"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson pkgconfig
+
+require pldm.inc
+
+DEPENDS += "systemd"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "nlohmann-json"
+DEPENDS += "boost"
+DEPENDS += "cli11"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ -Doem-ibm=disabled \
+ "
diff --git a/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb b/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
index 1d70a0c3f..d3cd73c7f 100644
--- a/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "dbus-sensors"
DESCRIPTION = "Dbus Sensor Services Configured from D-Bus"
SRC_URI = "git://github.com/openbmc/dbus-sensors.git"
-SRCREV = "1a70a588dc6d57e68e684a789f46178efeeaf1cb"
+SRCREV = "4316218ab824c3c60f566b38f620a6d778e45a83"
PV = "0.1+git${SRCPV}"
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
index 6697c7a3d..e3d276ea2 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -39,7 +39,7 @@ SRC_URI += "file://70-hwmon.rules"
SRC_URI += "file://70-iio.rules"
SRC_URI += "file://start_hwmon.sh"
-SRCREV = "778f5c39b1e53ee291f10a6d4d13d8fb16bbc112"
+SRCREV = "ddbf1c68e33f18797fafffc4615b19178b9fdb8d"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 7cae3902a..c30d191ec 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -147,6 +147,6 @@ do_install_append() {
}
SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
-SRCREV = "60c3ac8c874da1a037cb338ca033655a122aca9d"
+SRCREV = "a6e7bbf0d63b33382448a62ae08661ef17f60e64"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
index 82c78a915..766074e58 100644
--- a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
@@ -6,7 +6,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/openbmc/phosphor-webui.git"
-SRCREV = "ff7f10685d0ce060bf2d1a90872c0c6016711b41"
+SRCREV = "5e930c0aeb5b66df2c357be4d5c33d4828c2783f"
S = "${WORKDIR}/git"
DEPENDS_prepend = "nodejs-native "