summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
new file mode 100644
index 000000000..b29372727
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Entity Manager"
+DESCRIPTION = "Entity Manager provides d-bus configuration data \
+and configures system sensors"
+
+SRC_URI = "git://github.com/openbmc/entity-manager.git"
+SRCREV = "b5e32c2396ac531f14d45d29dd4c6e159dcb1e0f"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
+ xyz.openbmc_project.FruDevice.service"
+
+PROVIDES += "virtual/phosphor-fans-sensor-inventory"
+DEPENDS = "boost \
+ i2c-tools \
+ nlohmann-json \
+ sdbusplus \
+ valijson"
+
+S = "${WORKDIR}/git/"
+inherit cmake systemd
+
+EXTRA_OECMAKE = "-DYOCTO=1 -DUSE_OVERLAYS=0"
+