summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb5
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config/entity-map.json15
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host/entity.yaml13
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb12
4 files changed, 19 insertions, 26 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
index 02a7c643b..8de43d28f 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -13,6 +13,7 @@ SRC_URI = " \
file://power_reading.json \
file://channel_access.json \
file://channel_config.json \
+ file://entity-map.json \
"
FILES_${PN} = " \
@@ -23,6 +24,7 @@ FILES_${PN} = " \
${datadir}/ipmi-providers/power_reading.json \
${datadir}/ipmi-providers/channel_access.json \
${datadir}/ipmi-providers/channel_config.json \
+ ${datadir}/ipmi-providers/entity-map.json \
"
do_fetch[noexec] = "1"
@@ -46,5 +48,6 @@ do_install() {
${D}${datadir}/ipmi-providers/channel_access.json
install -m 0644 -D ${WORKDIR}/channel_config.json \
${D}${datadir}/ipmi-providers/channel_config.json
-
+ install -m 0644 -D ${WORKDIR}/entity-map.json \
+ ${D}${datadir}/ipmi-providers/entity-map.json
}
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config/entity-map.json b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config/entity-map.json
new file mode 100644
index 000000000..cdb1ea847
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config/entity-map.json
@@ -0,0 +1,15 @@
+[
+ {
+ "id" : 1,
+ "containerEntityId" : 30,
+ "containerEntityInstance" : 1,
+ "isList" : true,
+ "isLinked" : false,
+ "entities" : [
+ {"id" : 3, "instance" : 1},
+ {"id" : 4, "instance" : 1},
+ {"id" : 0, "instance" : 0},
+ {"id" : 0, "instance" : 0}
+ ]
+ }
+]
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host/entity.yaml b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host/entity.yaml
deleted file mode 100644
index f41c2fda6..000000000
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host/entity.yaml
+++ /dev/null
@@ -1,13 +0,0 @@
-0x01:
- containerEntityId: 0x1E
- containerEntityInstance: 0x1
- isList: "true"
- isLinked: "false"
- entityId1: 0x03
- entityInstance1: 0x1
- entityId2: 0x04
- entityInstance2: 0x1
- entityId3: 0x00
- entityInstance3: 0x00
- entityId4: 0x00
- entityInstance4: 0x00
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 1df091fe2..f654d0ce6 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -14,8 +14,6 @@ inherit obmc-phosphor-systemd
inherit phosphor-ipmi-host
inherit pythonnative
-SRC_URI += "file://entity.yaml"
-
def ipmi_whitelists(d):
whitelists = d.getVar(
'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
@@ -103,16 +101,6 @@ SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
-do_replace_entity_default() {
- # The in-repo provided default is tailored to testing the ipmid code.
- # Replace it with a reasonable default for users.
- cp ${THISDIR}/${PN}/entity.yaml ${S}/scripts/entity-example.yaml
-}
-
-do_patch_append() {
- bb.build.exec_func('do_replace_entity_default', d)
-}
-
#Collect all hardcoded sensor yamls from different recipes and
#merge all of them with sensor.yaml.
python do_merge_sensors () {