summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb')
-rw-r--r--meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb b/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb
new file mode 100644
index 000000000..5b63e49cb
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb
@@ -0,0 +1,21 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit systemd
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=git"
+SRCREV = "08b87370c56ff69df852eca87391ae46c05d437a"
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "systemd"
+
+FILES_${PN} += "${bindir}/mac-address"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "mac-address.service"
+
+EXTRA_OECONF = " \
+ SYSTEMD_TARGET="multi-user.target" \
+"