summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/boot-status-led/files/boot-status-led.service2
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.service11
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.sh70
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/gbs-detect-fan-fail.bb25
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/files/detect-gpio-present.sh11
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/files/entity_association_map.json3
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/files/gbs-sysinit.service2
7 files changed, 13 insertions, 111 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/files/boot-status-led.service b/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/files/boot-status-led.service
index ea44dda2d..ab4622efa 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/files/boot-status-led.service
+++ b/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/files/boot-status-led.service
@@ -7,7 +7,7 @@ Wants=xyz.openbmc_project.LED.GroupManager.service
ExecStart=/usr/bin/boot-status-led.sh
StandardOutput=syslog
Type=simple
-Restart=yes
+Restart=on-failure
[Install]
WantedBy=multi-user.target
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.service b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.service
deleted file mode 100644
index ecdc95399..000000000
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Detect Fan Fail Manager
-After=phosphor-pid-control.service
-
-[Service]
-ExecStart=/usr/bin/gbs-detect-fan-fail.sh
-Restart=always
-StandardOutput=syslog
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.sh b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.sh
deleted file mode 100644
index 56ae7bbc5..000000000
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/files/gbs-detect-fan-fail.sh
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/bash
-
-##
- # This script is to handle fan fail condition which is described below.
- # Fan fail means one fan RPM is under its CriticalLow. If BMC encounters
- # such situation, then sets other fans to full speed.
- #
-
-# get fan state
-function get_fan_state() {
- get_property_path='xyz.openbmc_project.Sensor.Threshold.Critical CriticalAlarmLow'
- fan_state="$(busctl get-property $1 $2 $get_property_path | awk '{print $2}')"
- echo "$fan_state"
-}
-
-# check fan fail
-function is_fan_fail() {
- fan_state=("$@")
-
- for i in "${fan_state[@]}"
- do
- if [ ! -z "$i" ]
- then
- if [ $i == "true" ]
- then
- echo 1
- return
- fi
- fi
- done
- echo 0
-}
-
-fan_tach_path=( '/xyz/openbmc_project/sensors/fan_tach/fan0'
- '/xyz/openbmc_project/sensors/fan_tach/fan1'
- '/xyz/openbmc_project/sensors/fan_tach/fb_fan0'
- '/xyz/openbmc_project/sensors/fan_tach/fb_fan1'
- '/xyz/openbmc_project/sensors/fan_tach/fb_fan2'
- )
-
-check_fail_flag=0
-is_fan_fail_flag=0
-current_fan_state=()
-
-while true
-do
- for i in ${!fan_tach_path[@]}
- do
- mapper wait ${fan_tach_path[$i]}
- hwmon_path="$(mapper get-service ${fan_tach_path[0]})"
- current_fan_state[$i]=$(get_fan_state $hwmon_path ${fan_tach_path[$i]})
- done
-
- is_fan_fail_flag=$(is_fan_fail "${current_fan_state[@]}")
-
- # if fan fails then set all fans to full speed
- if [ $is_fan_fail_flag -eq 1 ] && [ $check_fail_flag -eq 0 ]
- then
- check_fail_flag=1
- systemctl stop phosphor-pid-control.service
-
- # fans recover to normal state
- elif [ $is_fan_fail_flag -eq 0 ] && [ $check_fail_flag -eq 1 ]
- then
- check_fail_flag=0
- systemctl restart phosphor-pid-control.service
- fi
-
- sleep 2
-done
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/gbs-detect-fan-fail.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/gbs-detect-fan-fail.bb
deleted file mode 100644
index 5befec8d6..000000000
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-fan-fail/gbs-detect-fan-fail.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "OpenBMC Quanta Detect Fan Fail Service"
-DESCRIPTION = "OpenBMC Quanta Detect Fan Fail Daemon."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-
-DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
-
-SRC_URI = " file://gbs-detect-fan-fail.sh \
- file://gbs-detect-fan-fail.service \
- "
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/gbs-detect-fan-fail.sh ${D}${bindir}/
-
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/gbs-detect-fan-fail.service ${D}${systemd_system_unitdir}
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "gbs-detect-fan-fail.service"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/files/detect-gpio-present.sh b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/files/detect-gpio-present.sh
index 2bbe46e84..dd5852a70 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/files/detect-gpio-present.sh
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/files/detect-gpio-present.sh
@@ -10,7 +10,8 @@ PRESENT_OBJPATH=("/xyz/openbmc_project/inventory/system/chassis/cable/ss_cab0_pr
"/xyz/openbmc_project/inventory/system/chassis/cable/bp12v_cab_prsnt"
"/xyz/openbmc_project/inventory/system/chassis/entity/sata0_prsnt"
"/xyz/openbmc_project/inventory/system/chassis/entity/pe_slot0_prsnt"
-"/xyz/openbmc_project/inventory/system/chassis/entity/pe_slot1_prsnt")
+"/xyz/openbmc_project/inventory/system/chassis/entity/pe_slot1_prsnt"
+"/xyz/openbmc_project/inventory/system/chassis/entity/fans_efuse_pg")
INTERFACE_NAME="xyz.openbmc_project.Inventory.Item"
IPMI_LOG_SERVICE="xyz.openbmc_project.Logging.IPMI"
@@ -23,12 +24,16 @@ LOG_EVENT_DATA="3 0x01 0xff 0xfe"
LOG_ASSERT_FLAG="true"
LOG_DEASSERT_FLAG="false"
LOG_GENID_FLAG="0x0020"
-present_state=("true" "true" "true" "true" "true" "true" "true" "true" "true" "true")
+present_state=("true" "true" "true" "true" "true" "true" "true" "true" "true" "true" "true")
+
+for i in ${!PRESENT_OBJPATH[@]}
+do
+ mapper wait ${PRESENT_OBJPATH[$i]}
+done
while true; do
for i in ${!PRESENT_OBJPATH[@]}
do
- mapper wait ${PRESENT_OBJPATH[$i]}
boot_status="$(busctl get-property $SERVICE_NAME ${PRESENT_OBJPATH[$i]} $INTERFACE_NAME Present | awk '{print $2}')"
if [ $boot_status == "false" ] && [ ${present_state[$i]} == "true" ];then
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/files/entity_association_map.json b/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/files/entity_association_map.json
index f4e453a9a..f430dcf00 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/files/entity_association_map.json
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/files/entity_association_map.json
@@ -24,6 +24,7 @@
],
"cooling_unit": [
{"instance": 0, "name": "/ZONE0"},
- {"instance": 1, "name": "/ZONE1"}
+ {"instance": 1, "name": "/ZONE1"},
+ {"instance": 2, "name": "/ZONE2"}
]
}
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/files/gbs-sysinit.service b/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/files/gbs-sysinit.service
index 645136b85..7fd74377c 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/files/gbs-sysinit.service
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/files/gbs-sysinit.service
@@ -1,5 +1,7 @@
[Unit]
Description = Initialization for GBS boot up
+Requires=gbs-host-ready.target
+After=gbs-host-ready.target
Wants=mapper-wait@-xyz-openbmc_project-inventory.service
After=mapper-wait@-xyz-openbmc_project-inventory.service
Wants=mapper-wait@-xyz-openbmc_project-control-nvme.service