summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-quanta/network/mac-address_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-quanta/network/mac-address_%.bbappend')
-rw-r--r--meta-quanta/meta-gbs/recipes-quanta/network/mac-address_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-quanta/network/mac-address_%.bbappend b/meta-quanta/meta-gbs/recipes-quanta/network/mac-address_%.bbappend
new file mode 100644
index 000000000..d975fe28b
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-quanta/network/mac-address_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://config.txt"
+
+FILES_${PN}_append_gbs = " ${datadir}/mac-address/config.txt"
+
+do_install_append_gbs() {
+ install -d ${D}${datadir}/mac-address
+ install -m 0644 -D ${WORKDIR}/config.txt \
+ ${D}${datadir}/mac-address/config.txt
+}