summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend')
-rw-r--r--meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
index 33cc6d4e0..348ad1043 100644
--- a/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,14 +1,14 @@
-FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
-SRC_URI_append_gbs = " file://power-config-host0.json \
+FILESEXTRAPATHS:prepend:gbs := "${THISDIR}/${PN}:"
+SRC_URI:append:gbs = " file://power-config-host0.json \
file://chassis-system-reset.service \
"
-EXTRA_OECMAKE_append_gbs = " -DCHASSIS_SYSTEM_RESET=ON"
+EXTRA_OECMAKE:append:gbs = " -DCHASSIS_SYSTEM_RESET=ON"
-RDEPENDS_${PN}_append_gbs = " bash"
-RDEPENDS_${PN}_append_gbs = " gbs-hotswap-power-cycle"
+RDEPENDS:${PN}:append:gbs = " bash"
+RDEPENDS:${PN}:append:gbs = " gbs-hotswap-power-cycle"
-do_install_append_gbs() {
+do_install:append:gbs() {
install -d ${D}${datadir}/${PN}
install -m 0644 ${WORKDIR}/power-config-host0.json ${D}${datadir}/${PN}
}