summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-phosphor/ipmi')
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb19
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml7
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb
new file mode 100644
index 000000000..656fcb969
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "FRU properties config for ipmi-fru-parser"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://extra-properties.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${properties_datadir}
+ install -d ${DEST}
+ install extra-properties.yaml ${DEST}
+}
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml
new file mode 100644
index 000000000..8a5668295
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml
@@ -0,0 +1,7 @@
+/system/chassis/bmc:
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+
+/system/chassis/hsbp:
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'