summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
deleted file mode 100644
index d20312c14..000000000
--- a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
-LICENSE = "Broadcom-RPi"
-
-LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d"
-
-inherit deploy nopackages
-
-include recipes-bsp/common/raspberrypi-firmware.inc
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-DEPENDS = "rpi-config"
-
-COMPATIBLE_MACHINE = "^rpi$"
-
-S = "${RPIFW_S}/boot"
-
-PR = "r3"
-
-do_deploy() {
- install -d ${DEPLOYDIR}/${PN}
-
- for i in ${S}/*.elf ; do
- cp $i ${DEPLOYDIR}/${PN}
- done
- for i in ${S}/*.dat ; do
- cp $i ${DEPLOYDIR}/${PN}
- done
- for i in ${S}/*.bin ; do
- cp $i ${DEPLOYDIR}/${PN}
- done
-
- # Add stamp in deploy directory
- touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
-}
-
-do_deploy[depends] += "rpi-config:do_deploy"
-
-addtask deploy before do_build after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-