summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb29
1 files changed, 24 insertions, 5 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index de43c4b36..e84456c7a 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -30,6 +30,8 @@ GPIO_IR_TX ?= "17"
CAN_OSCILLATOR ?= "16000000"
+WM8960="${@bb.utils.contains("MACHINE_FEATURES", "wm8960", "1", "0", d)}"
+
inherit deploy nopackages
do_deploy() {
@@ -118,10 +120,15 @@ do_deploy() {
# Video camera support
if [ "${VIDEO_CAMERA}" = "1" ]; then
- # TODO: It has been observed that Raspberry Pi 4B 4GB may fail to enable the camera if "start_x=1" is at the end
- # of the file. The underlying cause is unknown, but it can be related with a file size limitation affecting
- # this variable. Therefore, "start_x=1" has been set to replace the original occurrence in config.txt,
- # which is at the middle of the file.
+ # It has been observed that Raspberry Pi 4B 4GB may fail to enable the
+ # camera if "start_x=1" is at the end of the file. Therefore,
+ # "start_x=1" has been set to replace the original occurrence in
+ # config.txt, which is at the middle of the file.
+ # The exact underlying cause is unknown. There are similar issues
+ # reported in the raspberrypi/firware repo and the conclusion reached
+ # was that there could be a file size limitation affecting certain
+ # variables. It was commented that this limitation could be 4k but
+ # not proved.
sed -i '/#start_x=/ c\start_x=1' $CONFIG
fi
@@ -184,10 +191,16 @@ do_deploy() {
# Choose Camera Sensor to be used, default imx219 sensor
if [ "${RASPBERRYPI_CAMERA_V2}" = "1" ]; then
- echo "# Enable Sony RaspberryPi Camera" >> $CONFIG
+ echo "# Enable Sony RaspberryPi Camera(imx219)" >> $CONFIG
echo "dtoverlay=imx219" >> $CONFIG
fi
+ # Choose Camera Sensor to be used, default imx477 sensor
+ #if [ "${RASPBERRYPI_HD_CAMERA}" = "1" ]; then
+ # echo "# Enable Sony RaspberryPi Camera(imx477)" >> $CONFIG
+ # echo "dtoverlay=imx477" >> $CONFIG
+ #fi
+
# Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> $CONFIG
@@ -240,6 +253,12 @@ do_deploy() {
;;
esac
fi
+
+ # WM8960 support
+ if [ "${WM8960}" = "1" ]; then
+ echo "# Enable WM8960" >> $CONFIG
+ echo "dtoverlay=wm8960-soundcard" >> $CONFIG
+ fi
}
do_deploy_append_raspberrypi3-64() {