summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend')
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
index cdfe5bb8b..154309e7f 100644
--- a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,15 +1,15 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append_rpi = " \
+SRC_URI:append:rpi = " \
file://fw_env.config \
"
# special fix for raspberrypi-cm3
-SRC_URI_append_raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch"
+SRC_URI:append:raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch"
-DEPENDS_append_rpi = " u-boot-default-script"
+DEPENDS:append:rpi = " u-boot-default-script"
-do_install_append_rpi () {
+do_install:append:rpi () {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
}