summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-connectivity/bluez5
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-connectivity/bluez5')
-rw-r--r--meta-raspberrypi/recipes-connectivity/bluez5/bluez5/brcm43438.service14
-rw-r--r--meta-raspberrypi/recipes-connectivity/bluez5/bluez5_%.bbappend35
2 files changed, 3 insertions, 46 deletions
diff --git a/meta-raspberrypi/recipes-connectivity/bluez5/bluez5/brcm43438.service b/meta-raspberrypi/recipes-connectivity/bluez5/bluez5/brcm43438.service
deleted file mode 100644
index a51f6bcbc..000000000
--- a/meta-raspberrypi/recipes-connectivity/bluez5/bluez5/brcm43438.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Broadcom BCM43438 bluetooth HCI
-ConditionPathIsDirectory=/proc/device-tree/soc/gpio@7e200000/bt_pins
-Before=bluetooth.service
-BindsTo=dev-serial1.device
-After=dev-serial1.device
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/usr/bin/btuart
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-raspberrypi/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-raspberrypi/recipes-connectivity/bluez5/bluez5_%.bbappend
index d1b84df43..6651fb8d3 100644
--- a/meta-raspberrypi/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-raspberrypi/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -5,41 +5,12 @@ BCM_BT_SOURCES = " \
file://0002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch \
file://0003-Increase-firmware-load-timeout-to-30s.patch \
file://0004-Move-the-43xx-firmware-into-lib-firmware.patch \
- file://brcm43438.service \
- "
-
-BCM_BT_SERVICE = "brcm43438.service"
-
-enable_bcm_bluetooth() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/${BCM_BT_SERVICE} ${D}${systemd_unitdir}/system
- fi
-}
-
-BCM_BT_RDEPENDS = "\
- udev-rules-rpi \
- pi-bluetooth \
"
-# for raspberrypi3
-SRC_URI_append_raspberrypi3 = " ${BCM_BT_SOURCES}"
-
-do_install_append_raspberrypi3() {
- enable_bcm_bluetooth
-}
-
-SYSTEMD_SERVICE_${PN}_append_raspberrypi3 = " ${BCM_BT_SERVICE}"
+BCM_BT_RDEPENDS = "pi-bluetooth"
-RDEPENDS_${PN}_append_raspberrypi3 = " ${BCM_BT_RDEPENDS}"
-
-# for raspberrypi0-wifi
SRC_URI_append_raspberrypi0-wifi = " ${BCM_BT_SOURCES}"
-
-do_install_append_raspberrypi0-wifi() {
- enable_bcm_bluetooth
-}
-
-SYSTEMD_SERVICE_${PN}_append_raspberrypi0-wifi = " ${BCM_BT_SERVICE}"
+SRC_URI_append_raspberrypi3 = " ${BCM_BT_SOURCES}"
RDEPENDS_${PN}_append_raspberrypi0-wifi = " ${BCM_BT_RDEPENDS}"
+RDEPENDS_${PN}_append_raspberrypi3 = " ${BCM_BT_RDEPENDS}"