summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-devtools')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch (renamed from meta-raspberrypi/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch)0
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb (renamed from meta-raspberrypi/recipes-devtools/python/python-rtimu_git.bb)2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-sense-hat_2.2.0.bb (renamed from meta-raspberrypi/recipes-devtools/python/python-sense-hat_2.2.0.bb)8
3 files changed, 5 insertions, 5 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch b/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
index 4a93a1ce9..4a93a1ce9 100644
--- a/meta-raspberrypi/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
+++ b/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
diff --git a/meta-raspberrypi/recipes-devtools/python/python-rtimu_git.bb b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
index 63c92b381..c0cb31100 100644
--- a/meta-raspberrypi/recipes-devtools/python/python-rtimu_git.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
@@ -12,4 +12,4 @@ SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
S = "${WORKDIR}/git/Linux/python/"
-inherit setuptools
+inherit setuptools3
diff --git a/meta-raspberrypi/recipes-devtools/python/python-sense-hat_2.2.0.bb b/meta-raspberrypi/recipes-devtools/python/python3-sense-hat_2.2.0.bb
index f7c4e349d..5ea00142a 100644
--- a/meta-raspberrypi/recipes-devtools/python/python-sense-hat_2.2.0.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-sense-hat_2.2.0.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
-inherit setuptools pypi
+inherit setuptools3 pypi
PYPI_PACKAGE = "sense-hat"
@@ -18,7 +18,7 @@ DEPENDS += " \
"
RDEPENDS_${PN} += " \
- python-numpy \
- python-rtimu \
- python-imaging \
+ ${PYTHON_PN}-numpy \
+ ${PYTHON_PN}-rtimu \
+ ${PYTHON_PN}-imaging \
"