summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-devtools')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb4
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
index c0cb31100..4f13a38bb 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
@@ -10,6 +10,6 @@ SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master
"
SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
-S = "${WORKDIR}/git/Linux/python/"
+S = "${WORKDIR}/git/Linux/python"
inherit setuptools3
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
index fcce88f83..8b13d53a6 100644
--- a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -12,3 +12,7 @@ SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
COMPATIBLE_MACHINE = "^rpi$"
+
+# ignore issues with -fno-common from gcc-10 until it's fixed in upstream:
+# https://sourceforge.net/p/raspberry-gpio-python/tickets/187/
+CFLAGS += "-fcommon"